Re: Regarding GLIB 2.29.8 instalation

Hi Team,


I am trying to compile and install GLIB2.29.8 on my SUSE Linux Enterprise server (11.1)machine. I have run following command to compile and install source.

1.       ./configure

2.       Make

3.       Make install


But still it is showing the old version(2.0)  only. Can you please help us what could the fault from my side.



By default, ./configure will install in /usr/local folder. If your library paths doesn't point to that, you will not be able to use them.
You should set

export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH

I guess you won't have troubles with GObject Introspection, since that folder is already present at $XDG_DATA_DIRS.

Ian L.

PS.: Sorry Polisetti for the double reply ;-)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]