Gtk+ 2.24, Gtk+3 and GLib 2.28 in the middle

Hi list:

I have this doubt, I have Gnome 2.32 installed and I want to develop and application using Gtk+3, my doubt is that my Gnome 2.32 using Gtk+ 2.24 requires GLib 2.26, and Gtk+ 3 requires GLib 2.28. will I need to replace my GLib 2.26 ? As far as I read both Gtk versions are can be installed together, and if both GLib versions are parallel installable, then there's no problem, if it is not, the Gtk+ 2.24 will compile with the new GLib 2.28 ?

Note: I do know I'm able to install my development enviroment on opt and start working without affecting my main system, I'm asking for installing those libraries on my main system.

I'm asking here first so I can yell at my distro package makers with a reason for not having Gtk+ 3 already avalaible for the users.

Thanks you


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]