Re: GTK+ 2.20.0 is now available for download...

El mié, 24-03-2010 a las 10:47 +0100, IMS escribió:
> Hello,
> I have a question about releases. 
> Is it usual to release a stable version (here Gtk 2.20.0) based on
> development librairies like Glib ???
> When I try to compile I have this message : 
> checking for BASE_DEPENDENCIES... configure: error: Package
> requirements (glib-2.0 >= 2.23.6    atk >= 1.29.2    pango >= 1.20
> cairo >= 1.6) were not met:
> Requested 'glib-2.0 >= 2.23.6' but version of GLib is 2.22.4
> Requested 'atk >= 1.29.2' but version of Atk is 1.20.0
> The last release of Glib is the 2.23.6 and is not stable (the 2.22
> should be stable) and the last stable version for atk is 1.28 and not
> the branch 1.29
> Any responses ?

I don't think it's so unusual, but what's unusual indeed is to have the
GTK+ release before the GLib one. This, to my understanding, is a bit
exceptional now, because of a few changes that are still ongoing in the
gvariant side of glib, which are necessary before GLib is made stable.
This should be happening briefly, I think, so it's not really a problem.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]