Gtk-WARNING **: Locale not supported by C library.

When I run linphone I get the error:

kornerr korenwork:~$ linphone-3
** Message: Found lang ru

(process:11306): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.

I tried to ask at linphone mailing list and got reply that it has nothing to do with linphone.
Googling it didn't gave any success either. I tried to set LANG to ru, ru_RU, ru_RU.UTF-8, ru_RU.utf8, ru_RU.cp1251, ru_RU.koi8r, that is all locales I have under /usr/lib/locale (I'm using Slackware 13.0).
All the answers found at Google only suggest to play with LANG variable or to recompile Libc. Since the distro contains glibc-i18n package I suspect it has all locales correctly compiled. Not sure how to check for sure.
I hope you can direct me to the docs describing what can cause this particular Gtk-WARNING. Today I've read gettext documentation, did a test localization for ru, and that worked fine.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]