cygwin 1.5.25 missing gtkrecentmanager.h

I installed cygwin to build a GTK2 program and was able to build a
test program but was unable to build my application.

I installed all gtk packages as well as some dependencies that were
not automatically selected (atk and cairo) as well as all the X11
files and autotools.

I was able to run autoconf and configure without modification (very
impressive) but when I tried to make I found that gtkRecentManager was
not defined.
In fact it seemed that gtkrecentmanager.h was missing from
/usr/include/gtk-2.0/gtk along with 30 other files (208 files on my
Linux box, 178 in cygwin.)

Any ideas what might have caused this?
Are there widgets that are not available on non-unix platforms?

Thank you for your time,
    Soren Berg

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]