How to remove the old version of GLib


        I have just installed Glib-2.18.4 and now I'm trying to install atk-1.24.0 but I am getting this error:

*** 'pkg-config --modversion glib-2.0' returned 2.18.4, but GLIB (2.4.7)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files

I installed Glib using ./configure --prefix=/usr

I am sure that my PKG_CONFIG_PATH was set correctly and it was pointing to directory of pkgconfig where glib-2.0.pc is located.
i already set LD_LIBRARY_PATH in my bash_profile pointing the directory of /usr/local/lib/pkgconfig


everytime I install atk, or pango-1.20.0, im getting this:

*** Glib 2.14.0 or better is required. The latest version of
*** Glib is always available from

seems that I really need to de-install the old version of GLIB

But how? I tried rpm -e --allmatches glib and i got error becuase of dependencies.
I followed
but there's still no luck.

How can I fix this one?



The information contained in this email is confidential and may contain proprietary information. It is meant solely for the intended recipient. Access to this email by anyone else is unauthorised. If you are not the intended recipient, any disclosure, copying, distribution or any action taken or omitted in reliance on this, is prohibited and may be unlawful.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]