Re: Runtime error on Linux (undefined symbol)


Thanks very much for the replies.

Your feedback was spot on.  Once I uninstalled out of /usr/local and
compiled and installed everything into /usr, 'vim - g' worked!  I now
have to get my fonts configured correctly, but I've definitely made

Thanks again for the assistance!

Best regards,


On Sun, Apr 05, 2009 at 04:37 PM PDT, Chris Vine wrote:
CV> On Sun, 5 Apr 2009 15:49:53 -0700
CV> Mun Johl <Mun Johl Emulex Com> wrote:
CV> > Hi,
CV> >
CV> > Thanks to folks on this list I was able to finally get gtk+ compiled
CV> > on my Red Hat Enterprise Linux v5.3 system.  However, I then complied
CV> > vim v7.2.148 with the gui (GTK2), and I got the following error when
CV> > I tried to run the vim with the gui:
CV> >
CV> > ./vim: symbol lookup error: /usr/local/lib/
CV> > undefined symbol: g_signal_new_class_handler
CV> >
CV> >
CV> > I compiled and installed into /usr/local the glib-2.20.0 and
CV> > gtk+-2.16.0 packages (and all of their dependencies),  Perhaps there
CV> > is a conflict with what was installed on my computer initially?
CV> >
CV> > BTW, I'm using gcc v4.1.2 .
CV> >
CV> > Any information on 'g_signal_new_class_handler' and how to resolve the
CV> > issue would be very much appreciated.
CV> You have two versions of glib and gtk+ (and probably other libraries
CV> such as pango, cairo and atk) installed on your system and the old
CV> version, presumably in the /usr prefix, is being picked up by the
CV> dynamic loader instead of the one you have placed in the /usr/local
CV> prefix.
CV> The best thing is not to go down this route at all, and to install your
CV> updated libraries by building them as RHEL packages which replace your
CV> existing ones. If however you insist on having two different versions of
CV> the same libraries installed on your system you might want to google
CV> for the LD_LIBRARY_PATH environmental variable.
CV> Chris

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]