Invalid GLib version in gtk+ bundle

I downloaded gtk+-bundle-2.12.11-20080720 and I try to compile pygtk-2.0.0.
But then configure script fails with the following messages:

checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.16.5, but GLIB (2.12.11)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error: maybe you want the gtk-gnome-1-2 branch?

That's funny because 2.12.11 is the version of gtk+, not glib. I try it with
this simple program:

#include <stdio.h>
#include <glib.h>

int main(){
  return 0;

Indeed, it differs. Should I fool pkg-config by changing GLIB_*_VERSION
macros (and Version in glib-2.0.pc) to match 2.12.11? I guess that will only
make things worse in the future.
View this message in context:
Sent from the Gtk+ - General mailing list archive at

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]