Problems trying to build gtk in Windows


I've been trying to compile GTK 2.24.14 under msys and hitting some
problems. My mingw/msys installation is pretty much the most recent versions
and I'm running it on a Vista 64 system. I have gcc 4.3.0 installed.

First I ran "./configure --without-libjasper" which finished successfully.

Next I ran make. It ran for a while then stopped at this line of output with
Windows reporting "This application has failed to start because
libglib-2.0-0.dll was not found":

Writing a gdk-pixbuf.loader file to use when running examples before
installing gdk-pixbuf.

I have my GTK installation bin directory on the PATH in both the msys and
Windows environments, and libglib-2.0-0.dll is in there, so I don't see why
it can't find that DLL?

In the end I had to manually copy all the dlls from GTK/bin into the
gdk-pixbuf source directory to get that program to run. So any idea why the
heck the above error would happen?

That got it past that error, but then quite some time later it failed with
this error:

creating gtk-update-icon-cache.exe
make[3]: Leaving directory
./gtk-update-icon-cache --force --ignore-theme-index \
           --source builtin_icons stock-icons > gtkbuiltincache.h.tmp && \
        mv gtkbuiltincache.h.tmp gtkbuiltincache.h
./gtk-update-icon-cache: line 104:
ache.exe: Bad file number
./gtk-update-icon-cache: line 104:
ache.exe: error 0
make[2]: *** [gtkbuiltincache.h] Error 1
make[2]: Leaving directory
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
make: *** [all] Error 2

I can force a re-make of gtk-update-icon-cache.exe, and the resultant exe
gives that "Bad file number" error when I try to run it:

[gtk]: rm gtk-update-icon-cache.exe
[gtk]: make gtk-update-icon-cache.exe
/bin/sh ../libtool --mode=link gcc  -DGDK_PIXBUF_DISABLE_DEPRECATED -g -O2
-Wall -mms-bitfields   -o gtk-update-icon-cache.exe  updateiconcache.o
../gdk-pixbuf/ -lintl 
gcc -DGDK_PIXBUF_DISABLE_DEPRECATED -g -O2 -Wall -mms-bitfields -o
.libs/gtk-update-icon-cache.exe updateiconcache.o
../gdk-pixbuf/.libs/libgdk_pixbuf-2.0.dll.a -Lc:/GTK/GTK-2.14.4/lib
-lgio-2.0 -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lole32 -lintl
creating gtk-update-icon-cache.exe
[gtk]: ./gtk-update-icon-cache.exe 
sh: ./gtk-update-icon-cache.exe: Bad file number
[gtk]: .libs/gtk-update-icon-cache.exe 
sh: .libs/gtk-update-icon-cache.exe: Bad file number

Any ideas on the cause of this one?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]