Re: [gtkextra] No text is drawn

Sorry for the late appearance in the discussion but I just switched jobs and moved to Santa Barbara, and I'm back to work. I committed a couple of lines of code that are supoused to fix this. can anybody try it out? Thank you!

Christoph Finke wrote:

I had the same Problem,
its a bug in gtkextra/gtkfontps.c (or perhaps deeper in the pango-library)

Line 467
 if (!g_object_class_find_property(klass, "gtk-xft-dpi")) {
   dpi = 96.;
 } else {
   /* Read the settings. */
   gint int_dpi;
            "gtk-xft-dpi", &int_dpi,
   dpi = int_dpi / PANGO_SCALE;

g_object_get returns 0.

I have put the following line in ~/.gtkrc-2.0 (outside of any style block):
which solved the Problem.

Christoph Finke

----- Original Message ----- From: <romildo uber com br>
To: "Owen Taylor" <otaylor redhat com>
Cc: <scigraphica-gtkextra lists sourceforge net>; <gtk-list gnome org>
Sent: Wednesday, August 03, 2005 2:35 PM
Subject: Re: [gtkextra] No text is drawn

On Sat, Jul 30, 2005 at 08:54:14AM -0400, Owen Taylor wrote:

GTK+ and Xft will use in order:

 - Xft.dpi X resource
 - DPI from the screen

I do not set DisplaySize in the Xorg configuration file,
and from /var/log/Xorg.0.log I have

(II) NVIDIA(0): Virtual screen size determined to be 1400 x 1050
(--) NVIDIA(0): Display dimensions: (320, 240) mm
(--) NVIDIA(0): DPI set to (111, 111)

which is correct for my monitor. Therefore the DPI from
the screen seems to be ok. Nontheless the test programs
from gtk+extra has a text size very very small and
unreadable size.

Also setting the DPI in the X resource file does not
change this situation. I have tried setting it with

Xft.dpi: 100

in my ~/.Xresources file. Other applications, such as
the gnome-panel, see this setting and changes the
font size accordingly, but the gtk+extra test
programs still draw their text in the same very
small and unreadable font size.

Regarding the first option (Xft/DPI XSETTING), I do
not know how to set it, so that it can be tried. Maybe
someone can help me with it.

So if gnome-settings-daemon isn't there to provide the DPI, it will
*still* have a DPI. GTK+ works perfectly fine in non-GNOME environments.

I still does not understand why those test programs
from gtk+extra do use such a very small font size.
What else can I do to get it right?


SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast.
Scigraphica-gtkextra mailing list
Scigraphica-gtkextra lists sourceforge net

gtk-list mailing list
gtk-list gnome org


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]