Re: GTK Can't Find libtiff


JS <oghistorian yahoo com> writes:

> As I continue on my quest to get GIMP running on MacOS
> 10.2.6, I have again ran into a snare with
> installation.  This time it deals with GTK itself. 
> After compiling and installing Pango, I tried to
> compile GTK again.  Well, it came up with another
> dependency that I needed to install, libtiff.  So I
> went to the GTK site and downloaded the libtiff
> dependency and compiled and installed it without a
> problem.  Then I went back to GTK and tried to compile
> it, but it is still asking for libtiff.  Here is a
> portion of the log:
> checking for TIFFReadScanline in -ltiff... no
> checking for TIFFWriteScanline in -ltiff... no
> checking for TIFFFlushData in -ltiff34... no
> configure: WARNING: *** TIFF plug-in will not be built
> (TIFF library not found) ***
> configure: error:
> *** Checks for TIFF loader failed. You can build
> without it by passing
> *** --without-libtiff to configure but some programs
> using GTK+ may
> *** not work properly

If all else fails, you could disable tiff support as explained in the
error message above. It's not really vital for most GTK+ applications,
definitely not for GIMP. But since you will want to compile the tiff
plug-in in GIMP later, we better tell you how to persuade configure to
find libtiff...

Check the output of configure --help. It tells you how to add linker,
compiler and preprocessor flags. What you will need here is something

 LDFLAGS=-L/usr/local/lib ./configure


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]