GTK Can't Find libtiff

Hi All,

As I continue on my quest to get GIMP running on MacOS
10.2.6, I have again ran into a snare with
installation.  This time it deals with GTK itself. 
After compiling and installing Pango, I tried to
compile GTK again.  Well, it came up with another
dependency that I needed to install, libtiff.  So I
went to the GTK site and downloaded the libtiff
dependency and compiled and installed it without a
problem.  Then I went back to GTK and tried to compile
it, but it is still asking for libtiff.  Here is a
portion of the log:

checking for extra flags for POSIX compliance... 
configure: WARNING: Could not determine POSIX flag.
(-posix didn't work.)
checking for pkg-config... (cached)
checking for GLIB - version >= 2.1.4... yes (version
checking for bind_textdomain_codeset... (cached) yes
checking pwd.h usability... yes
checking pwd.h presence... yes
checking for pwd.h... yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking for unistd.h... (cached) yes
checking for ANSI C header files... (cached) yes
checking for an ANSI C-conforming const... yes
checking return type of signal handlers... void
checking for stdlib.h... (cached) yes
checking for unistd.h... (cached) yes
checking for getpagesize... yes
checking for working mmap... yes
checking for getresuid... no
checking for uid_t in sys/types.h... yes
checking for fd_set... yes, found in sys/types.h
checking for wchar.h... no
checking for wctype.h... no
checking for iswalnum... no
checking for iswalnum in -lw... no
checking if iswalnum() and friends are properly
defined... yes
checking whether to build gmodulized gdk-pixbuf... yes
checking whether dynamic modules work... yes
checking for TIFFReadScanline in -ltiff... no
checking for TIFFWriteScanline in -ltiff... no
checking for TIFFFlushData in -ltiff34... no
configure: WARNING: *** TIFF plug-in will not be built
(TIFF library not found) ***
configure: error:
*** Checks for TIFF loader failed. You can build
without it by passing
*** --without-libtiff to configure but some programs
using GTK+ may
*** not work properly

Anyhelp on getting GTK to find libtiff would be great.
Also, should I worry about the error message about
POSIX compliance at the top of the log?

Thanks again,
J Silverman

Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]