Re: gtk-list digest, Vol 1 #1610 - 5 msgs

Thanks Melvin, that worked.


From: gtk-list-request gnome org
Reply-To: gtk-list gnome org
To: gtk-list gnome org
Subject: gtk-list digest, Vol 1 #1610 - 5 msgs
Date: Wed, 16 Jul 2003 12:00:09 -0400

Send gtk-list mailing list submissions to
	gtk-list gnome org

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to
	gtk-list-request gnome org

You can reach the person managing the list at
	gtk-list-admin gnome org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of gtk-list digest..."

Today's Topics:

   1. Compile problem with ld (Billy Bob)
   2. Re: Compile problem with ld (Melvin Hadasht)
   3. glib-1.2.10 make error ? (Nagaraja)
   4. about gdktarget (myong)
   5. GtkCellRendererPixbuf and signals (Andrej Prsa)


Message: 1
From: "Billy Bob" <trashbox777 hotmail com>
To: gtk-list gnome org
Subject: Compile problem with ld
Date: Tue, 15 Jul 2003 17:15:23 +0000

I am having trouble compling GTK, and any help would be appreciated:

I am trying to install GTK on:

Linux version 2.4.20-18.8 (bhcompile daffy perf redhat com) (gcc version 3.2
20020903 (Red Hat Linux 8.0 3.2-7)) #1 Thu May 29 07:40:27 EDT 2003

It is a little complicated by the fact that I do not have access to root, so
everything I install is in $HOME/usr.

I have downloaded glib-2.2.0, pango-1.2.3, atk-1.2.4, jpeg-6b, tiff-v3.5.7
and installed them all in my $HOME/usr directory ($HOME/usr/bin,
$HOME/usr/lib, ect..).

I downloaded gtk+-2.2.2, and used ./configure --prefix=$HOME/usr/local

but, to get the configure script to recgonize everything I had to create the
following environment variables:

LDFLAGS=-L $HOME/usr/lib

So then the configure script works fine, but when I type make, it gets to
the gtk+-2.2.2/gdk-pixbuf/pixops/  folder and prints the following:

make[3]: Entering directory
/bin/sh ../../libtool --mode=link gcc  -g -O2 -Wall -L /home/s03bpa/usr/lib
-o timescale  timescale.o -Wl,--export-dynamic -pthread
-L/home/s03bpa/usr//lib -lgobject-2.0 -lgmodule-2.0 -ldl -lgthread-2.0
-lglib-2.0   -lm
gcc -g -O2 -Wall /home/s03bpa/usr/lib -o timescale timescale.o
-Wl,--export-dynamic -pthread
-L/home/s03bpa/usr/src/gtk/gtk+-2.2.2/gdk-pixbuf/pixops ./.libs/libpixops.a
-L/home/s03bpa/usr//lib /home/s03bpa/usr//lib/
/home/s03bpa/usr//lib/ -ldl
/home/s03bpa/usr//lib/ -lpthread
/home/s03bpa/usr//lib/ -lm -Wl,--rpath
-Wl,/home/s03bpa/usr//lib -Wl,--rpath -Wl,/home/s03bpa/usr//lib
/home/s03bpa/usr/lib: file not recognized: Is a directory
collect2: ld returned 1 exit status
make[3]: *** [timescale] Error 1
make[3]: Leaving directory

Can anyone see what I've done wrong, or why this error appears?  I cannot
decipher it.


MSN 8 with e-mail virus protection service: 2 months FREE*


Message: 2
Date: Tue, 15 Jul 2003 19:40:32 +0200
To: gtk-list gnome org
From: Melvin Hadasht <melvin hadasht free fr>
Subject: Re: Compile problem with ld

Hi Billy,

You wrote:
> LDFLAGS=-L $HOME/usr/lib

There must not be a space between -L and the directory,
so it should read:


Melvin Hadasht


Message: 3
Date: Wed, 16 Jul 2003 13:47:57 +0530
From: Nagaraja <nagaraja ncoretech com>
To: gtk-list gnome org
Subject: glib-1.2.10 make error ?

Hi All,

I am trying to compile gtk-1.2.10 ,while configuring it stop with error :

configure: error:
*** GLIB 1.2.8 or better is required. The latest version of GLIB

my present GLIB is 1.2.7.  So  I tried recompiling  glib-1.2.10 and got
this error:

Making all in gthread
make[2]: Entering directory `/home/BUILD/glib-1.2.10/gthread'
/bin/sh ../libtool --mode=link gcc  -g -O2 -Wall  -D_REENTRANT  -o
testgthread  testgthread.o ../
gcc -g -O2 -Wall -D_REENTRANT -o .libs/testgthread testgthread.o
../.libs/ .libs/
testgthread.o: In function `new_thread':
/home/BUILD/glib-1.2.10/gthread/testgthread.c:89: undefined reference to
testgthread.o: In function `test_private':
/home/BUILD/glib-1.2.10/gthread/testgthread.c:197: undefined reference
to `pthread_join'
.libs/ undefined reference to `pthread_getspecific'
.libs/ undefined reference to `pthread_key_create'
.libs/ undefined reference to `pthread_mutex_trylock'
.libs/ undefined reference to `pthread_cond_timedwait'
.libs/ undefined reference to `pthread_setspecific'
collect2: ld returned 1 exit status
make[2]: *** [testgthread] Error 1
make[2]: Leaving directory `/home/BUILD/glib-1.2.10/gthread'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/BUILD/glib-1.2.10'
make: *** [all-recursive-am] Error 2

Could anyone please tell me as to  what  this error message would signify.

my host machine is armsa1110 using binutils-2.10.91 gcc-2.95.3 and
glibc-2.2.2 .

My build enviroment seems to be  OK since I manage to build a new
toolchain with binutils- gcc-2.95.3 and glibc-2.2.5

Thanks in advance


Message: 4
Date: Wed, 16 Jul 2003 16:15:20 +0800
From: myong <tottimyong netscape net>
To: gtk-list <gtk-list gnome org>
Subject: about gdktarget


      By using --with-gdktarget argument, I can select running platform at
configuring and compiling of gtk lib(default is X11). I want to run
programme at both X11 and framebuffer mode.

      if I use "configure --with-gdktarget=linux-fb" configure gtk lib,
can I arrive above target?


Message: 5
Date: Wed, 16 Jul 2003 13:17:46 +0200
From: Andrej Prsa <andrej prsa guest arnes si>
To: GTK Mailing list <gtk-list gnome org>
Subject: GtkCellRendererPixbuf and signals
Organization: Faculty of Mathematics and Physics


Could anyone please give me a hint on how to attach a "clicked" signal to
the pixbuf that is in the GtkTreeView? GtkCellRendererPixbuf doesn't have
any signals?



PS. Thanks, Murray, for your answer(s); I worked my way through editable


gtk-list mailing list
gtk-list gnome org

End of gtk-list Digest

Add photos to your messages with MSN 8. Get 2 months FREE*.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]