Problem with Pango On IBM AIX 4.3.3

I've tried to compile the glib-2.2.1 pango-1.2.1 atk-1.2.0 and
gtk+-2.2.1 on IBM
with AIX 4.3.3 using xlc compiler and not gcc
The compilation was made succesfull after some minor changes in Makefiles.

When compiling the above packages with configure --enable-static=yes and
all the demos programs from gtk+-2.2.1 work as well.

But when I compile all the above with configure --enable-shared=yes
which is the default
the compilation was succesful.
But when running examples from demos of gtk+-2.2.1 all the examples that
uses pango fonts
crashed with segmentation fault (core dumbed).

When debugging all the examples crashes at
function   pango_x_get_context  at
   file pangox.c at line 311
when calling  info = g_new(PangoXContextInfo,1);

After some trials to find the problem I'realized that all glib functions
that called from
pango has problem.Because

I've changed the above line with :
    info = (PangoXContextInfo *)malloc(sizeof(PangoXContextInfo));

and then crashed at g_object_set_qdata_full in the same function
4 lines beyond.

I'am very complicated because when i use static libraries everything is
working as well
I've tried some examples that don't load pango font like pixbufdemo and
work well with
shared libraries.

After all I've tried to compile the above packages using gcc that i'have
download from
ucla university.The compilation was succesfull.But I have exactly the
same problems with
shared libraries.

Did anyone have some ideas for the above.

Thanks in advance
Bill Souliotis

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]