Re: Error when usinf NCD Xterminal


Owen can answer this better but is out of town, so I'll try.

Kevin Handy <kth srv net> writes:
> I am getting the following error twice (always 2 copies of this error)
> on an NCD hmx Xterminal whenever I try to run anything using gtk.
> Xlib: extension "XInputExtension" missing on display "sales:0.0"

Is the error fatal or is it just printing this and moving on?

If nothing else you could perhaps rebuild GTK and pass
--with-xinput=no to configure, then it won't try to use xinput.

> Looking at xdpyinfo for the terminal in question, it lists
> "XInputExtension" as being there, among many other extensions.

If the terminal lists the extension but doesn't actually support it,
then that would certainly confuse GTK. (Or more accurately, it
probably confuses Xlib, but GTK is using the Xlib functions that use
this extension.) The X terminal is definitely badly broken if it does
this kind of false advertising, though.

> These programs work on older NCD Xterminals, and on some really old
> NDS Xterminals, but not this particular model.

You are saying GTK works on the older terminals? Do they have the X
input extension?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]