RE: installing 2.8

I did notice when I type 'gtk-config --libs' at the prompt I get message 
'gtk-config: Command not found' instead of the nice
-L /usr/local/lib   ...... -lgtk     and all that interesting stuff.

-----Original Message-----
From:	Matt Eisemann [SMTP:meisemann dsrnet com]
Sent:	Friday, October 27, 2000 2:50 PM
To:	'Matt Eisemann'; 'Dugas, Alan'; 'gtk-list gnome org'
Subject:	RE: installing 2.8

Could the below message be due to the fact that I used a prefix and not the 
default /usr/lib when I did my installation.  Do I need to redirect the c 
shell or set some env variable since that seems to be the case but I am not 
sure.  FYI when I ran ./configure i did ./configure 
--prefix=/home/matt/..... not the default /usr/lib.

-----Original Message-----
From:	Matt Eisemann [SMTP:meisemann dsrnet com]
Sent:	Friday, October 27, 2000 2:08 PM
To:	'Dugas, Alan'; gtk-list gnome org
Subject:	RE: installing 2.8

The installation of GTK+ worked fine, thanks.  When I compile my 
application though I get a message that
/bin/sh: gtk-config: not found

and when I try and run the executeable since it seems to link it, I get a 
message ./utics: fatal: open failed: No such file or 

It looks like GTK installed ok though so I am not sure what went wrong. 
 Ever see these error messages before and what do they mean?


-----Original Message-----
From:	Dugas, Alan [SMTP:alan dugas analog com]
Sent:	Thursday, October 26, 2000 4:34 PM
To:	gtk-list gnome org; Matt Eisemann
Subject:	RE: installing 2.8

Have you set environmental variables GLIB_CONFIG to point to the 
file and LD_LIBRARY_PATH to include the directory containing the glib
libraries?  These are environmental variables I had to set in order for me
to get glib-1.2.8 and gtk+-1.2.8 installed locally (i.e. without root
privleges) on a SPARC20.  Using this approach I managed to get both working
under Solaris 5.6 and SunOS 4.1.4.

				-- Stupid Genius

> ----------
> From: 	Matt Eisemann[SMTP:meisemann dsrnet com]
> Sent: 	Thursday, October 26, 2000 4:00 PM
> To: 	gtk-list gnome org
> Subject: 	installing 2.8
> Trying unsuccessfully to install GTK 1.2.8.  It looks like I succeffully
> installed GLIB successfully and I downloaded 1.2.8 for both versions of
> GTK+ and GLIB.  I am installing this on a Sun Solaris 2.6 machine, as far 
> as I know and it seems the GLIB works succefully.  When I did the
>    ./configure --prefix=/home/matt/mppcm/ssep/GTK/glib/glib-1.2.8
> both the make and the make install seemed to work but I did not check
> everything that was printed out.
> For GTK+, I also did a similar command
>       ./configure --prefix=/home/matt/mppcm/ssep/GTK/gtk+-1.2.8
> and it seemed to work fine for a while till it got to the end where it
> said
> " checking for GLIB - version >= 1.2.8 ... ./configure:
> /home/matt/mppcm/ssep/GTK/glib/glib-1.2.8: cannot execute
> ./configure: /home/matt/mppcm/ssep/GTK/glib/glib-1.2.8: cannot execute
> ./configure: /home/matt/mppcm/ssep/GTK/glib/glib-1.2.8: cannot execute
> ./configure: /home/matt/mppcm/ssep/GTK/glib/glib-1.2.8: cannot execute
> ./configure: /home/matt/mppcm/ssep/GTK/glib/glib-1.2.8: cannot execute
> no
> *** Could not run GLIB test program, checking why...
> *** The test program failed to compile or link.  See the file config.log
> for the
> *** exact error that occured.  This usually means GLIB was incorrectly
> installed
> *** or that you have moved GLIB since it was installed.  In the latter
> case, you
> *** may want to edit the glib-config script:
>  /home/matt/mppcm/ssep/GTK/glib/glib-1.2.8
> configure: error:
> *** GLIB 1.2.8 or better is required.  The latest version of GLIB
> *** is always available from
> any ideas what happened?  There did not seem to be any errors when I
> installed GLIB?  Since I do not have root privledge I have to use my 
> directory and not
> the /usr/local.
> Thanks for your help.
> Matt
> _______________________________________________
> gtk-list mailing list
> gtk-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]