Re: [gtk-list] Re: gtk or Xhost problem with linuxconf

>Just so you know this really isn't an appropriate place for such a question
>and I'm a pleasantly surprised no one has told you so in a less friendly way
>as of yet.

I appreciate everyone's willingness to help despite asking in the wrong 
place. I don't know the cause of the problem, so I guessed gtk.

If it were an xhost problem, it seems to me I should be getting the same 
error when I try to open any X application. If it were a linuxconf problem, 
other users would be seeing the same thing, and such a nasty bug as this 
would have been fixed by now. That's why I thought it might be at least 
partially a gtk problem.

What I don't understand is why linuxconf won't work when Gimp will. They 
both use gtk, so I assume I should be seeing the same problem with both, 
but I'm not. Wouldn't their gtk tidbits interact with xhost in exactly the 
same way?

Last word, before someone goes midevil on me for being clueless. For the 
record, I'm logging on as root in X windows, on the console, gnome is 
running, I haven't recompiled the kernel, and haven't made any changes to 
xhost permissions that I know of. I Installed linuxconf from an RPM I got 
from the home site.

I COULD fix the problem by typing xhost localhost every time I need to use 
linuxconf, but not knowing why it doesn't work just bugs the hell out of 
me. Even if I haven't fixed it yet, I've learned a lot through looking for 
the solution.


At 9:43 PM +0900 3/29/00, Richard M. Pavonarius wrote:
>I'm a somewhat newbie running RedHat 6.1, gnome desktop. I upgraded from 
>linuxconf-1.16r3.2-2 to 1.17r8-1 today.
>I'm logged in as root, not a user, at the console, not remotely. The first 
>or second time I try to run linuxconf I always get "Broken pipe"
>After that I always get:
>Error message from remadmin :
>Error message from remadmin :Gdk-WARNING **: locale not supported by C library
>Error message from remadmin :Xlib: connection to ":0.0" refused by server
>Error message from remadmin :Xlib: Invalid MIT-MAGIC-COOKIE-1 key
>Error message from remadmin :
>Error message from remadmin :Gtk WARNING **: cannot open display: :0
>So I set my locale to en_US with locale_config. Still get the "locale not 
>supported" error.
>Someone told me to try this:
>xhost localhost
>...and it allows me to run linuxconf. All other X apps work. Gimp works, 
>when linuxconf won't.
>If I type xhost as root I get "access control enabled, only authorized 
>clients can connect".
>If I type it in via telnet as a user I get xhost:  unable to open display ""
>What the heck is going on?

Richard M. Pavonarius, Global Commons, Inc., Tokyo

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]