Re: [gtk-list] gtk or Xhost problem with linuxconf

Xwindows has some basic  security in xhost (try man xhost).  To access
the Xserver you need to be allowed via xhost.  Try typing 'xhost<enter>' 
at the command prompt.  I get the following:

*[mcordes mcordes]$ xhost
*access control enabled, only authorized clients can connect

Notice, mine says ALL local connections are allowed.  If you don't have 
something like this only the user that started X will have the right to 
access it, thus if you su'ed to root and tried to run an X app you'd get a 
message about XLib refusing your connection ( as you listed below ).  
If your root user started the server either by typing 'startx' or via xdm 
you would only see this message if you su'ed to a non-root user.  the 
easiest fix is in your X startup file (either .Xclients, .xinitrc, .xsession, 
etc) in your home directory add 'xhost local:' this will allow all local 
user to access your machine whenever that user starts X.  If you want to 
do something more exotic read the xhost manpage.

The reason that when you su to root and try to add allowed clients with 
xhost is that the root user is not allowed to access X ( assuming you 
started it as some other user).  I'm a little surprised by this though, 
I thought RedHat came by default configured to allow all local connections
in the one of X's startup scripts, but I don't use RedHat so I couldn't 
tell you for sure.

Just so you know this really isn't an appropriate place for such a question
and I'm a pleasantly surprised no one has told you so in a less friendly way
as of yet.


On Wed, Mar 29, 2000 at 09:43:52PM +0900, Richard M. Pavonarius wrote:
> I'm a somewhat newbie running RedHat 6.1, gnome desktop. I upgraded from 
> linuxconf-1.16r3.2-2 to 1.17r8-1 today.
> I'm logged in as root, not a user, at the console, not remotely. The first 
> or second time I try to run linuxconf I always get "Broken pipe"
> After that I always get:
> Error message from remadmin :
> Error message from remadmin :Gdk-WARNING **: locale not supported by C library
> Error message from remadmin :Xlib: connection to ":0.0" refused by server
> Error message from remadmin :Xlib: Invalid MIT-MAGIC-COOKIE-1 key
> Error message from remadmin :
> Error message from remadmin :Gtk WARNING **: cannot open display: :0
> So I set my locale to en_US with locale_config. Still get the "locale not 
> supported" error.
> Someone told me to try this:
> xhost localhost
> ...and it allows me to run linuxconf. All other X apps work. Gimp works, 
> when linuxconf won't.
> If I type xhost as root I get "access control enabled, only authorized 
> clients can connect".
> If I type it in via telnet as a user I get xhost:  unable to open display ""
> What the heck is going on?
> Thanks,
> Rich
> ------------------------------------------------------------------
> Richard M. Pavonarius, Global Commons, Inc., Tokyo
> -- 
> To unsubscribe: mail -s unsubscribe < /dev/null

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]