RE: [gtk-list] Re: gtk 1.2.6 prob

-----Original Message-----
From: Erik Mouw []
Sent: Wednesday, January 19, 2000 9:34 AM
Subject: [gtk-list] Re: gtk 1.2.6 prob

On Wed, 19 Jan 2000 06:17:03 -0500, Bruce Lee wrote:
> Hi. I'm trying to install gtk1.2.6 and it keeps telling me that I need
> 1.2.6. Says my current version is 1.2.1 even though I went and got 1.2.6
> installed it
> without any errors. Running gtk1.2.6 the 2nd time, it still says I need to
> upgrade to do I solve this? I dont know how to check the
> current version of my glib or where it should be. So I dont know if the

"glib-config --cflags --libs" shows where glib is installed.

> program is making an error or if I"m doing something wrong...could you
> me solve this as easily as possible? Thanks. Easiest way to fix this says
> to remove the old glib...but how do I do that? do I rm -r
> /usr/local/lib/glib maybe? Here's my
> /usr/i486-linuxaout/lib

Still an a.out compatibility directory? Quite an old distribution.

> /usr/lib
> /usr/i486-linux-libc5/lib
> /usr/X11R6/lib

If you're using a Redhat RPM based Linux distribution, use rpm to remove
the older glib and gtk (see the RPM manpage). Than download the latest
gtk+glib 1.2.6 rpms and install those. For a Debian based distribution,
use dpkg, dselect or apt-get, and install the latest glib+gtk 1.2.6 debs.

If you installed glib 1.2.1 yourself from a tar file, the easiest way is
to use "make uninstall" in the glib 1.2.1 source directory. After that,
add "/usr/local/lib" to /etc/, run ldconfig, and configure and
install glib and gtk.


Yes, I'm using Redhat said to dload and install the latest gtk+glib
1.2.6 rpms...well, there aren't any that I could find..they all have to be
compiled and so when I run ./configure for gtk1.2.6, it  comes telling me
that glib 1.2.4 or better is required...actually, this is the full msg:

checking for GLIB - version >= 1.2.4...

*** 'glib-config --version' return 1.2.6, but GLIB (1.2.1)
*** was found! If glib-config was correct, then it is best
*** to remove the old version of GLIB.  You may also be able to fix the
*** by modifying your LD_LIBRARY_PATH environment variable, or by editting
*** /etc/  Make sure you have run ldconfig if that is
*** required on your system.
*** If glib-config was wrong, set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config, and remove the file
*** before re-running configure
configure: error:
*** GLIB 1.2.4 or better is required.

as for removing the old glib and gtk...they were installed with redhat so I
dont know the exact package names to remove. If I did know, I guess I'd be
saying: rpm -e package.rpm to remove it?



J.A.K. (Erik) Mouw, Information and Communication Theory Group, Department
of Electrical Engineering, Faculty of Information Technology and Systems,
Delft University of Technology, PO BOX 5031,  2600 GA Delft, The Netherlands
Phone: +31-15-2785859  Fax: +31-15-2781843  Email

To unsubscribe: mail -s unsubscribe < /dev/null

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]