Weird problems with keyboard

Hello, guys

I am getting a rather strange behavior when using the keyboard in
Gtk apps.  If I run any Gtk app on an Alpha with display on a
Linux/Sparc box running the XFree server, the program sigsegv's when I
press any key.  However, if I run it on an Intel box with display on
the Sparc, it works just fine.

Here is the un-useful stack trace I get on the first case:

(gdb) run
Starting program: /da/share/cvs/gtk+/gtk/.libs/testgtk 

Program received signal SIGSEGV, Segmentation fault.
warning: Hit beginning of text section without finding
warning: enclosing function for address 0xffe0
This warning occurs if you are debugging a function without any symbols
(for example, in a stripped executable).  In that case, you may wish to
increase the size of the search with the `set heuristic-fence-post' command.

Otherwise, you told GDB there was a function where there isn't one, or
(more likely) you have encountered a bug in GDB.
0xffe0 in ?? ()
(gdb) where
#0  0xffe0 in ?? ()
#1  0x15555b672c0 in XLookupString ()
#2  0x15555b672c0 in XLookupString ()
Cannot access memory at address 0xb0.

Any ideas?



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]