gtk+-1.0.0 - examples compile but don't run

I just built gtk+-1.0.0 under Solaris 2.6. After installing, I went to
the examples/helloworld directory and issued a "make", which worked fine.
However, when I tried to run the resulting binary, I get the following
error: ./helloworld: fatal: relocation error: file ./helloworld: 
    symbol __register_frame_info: referenced symbol not found

I also tried the initial "simplest program possible" from the online 
tutorial at, and got the same error. I looked through the 
online FAQ, and found nothing that looked relevant.

Has anyone seen something similar, and if so, what's the fix?

I built gtk with ./configure --prefix=/usr/local/gnu/test. I've set the
following in my environment:



I compiled with gcc 2.8.0 and gnu make 3.76.1.


John Abreau / UNIX Systems Administrator / Polaroid /
1 Upland Road, Building N4 / Norwood MA 02062 / 781-386-5118

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]