FontForge's pango displays text 10px under where expected


I reported a problem with Pango text rendering in FontForge, and was
referred here :-)

If anyone can fix this, I can offer a small tip via paypal :-)

Forwarded conversation
Subject: Font View window font is displayed 10px under where it should be?

From: Dave Crossland <dave lab6 com>
Date: 2009/1/12
To: fontforge-users <fontforge-users lists sourceforge net>


I've just installed FontForge from CVS on a fresh install of Fedora
10, and found the font used for labels in the Font View window is
displayed 10px under where it should be. I used the following

yum install libpng-devel zlib-devel libtiff-devel giflib-devel \
libjpeg-devel libxml2-devel libuninameslist-devel cairo-devel \
python-devel git subversion mercurial pango-devel;
yum groupinstall x-software-development development-tools;
cd ~;
mkdir src;
cd src;
cvs -d:pserver:anonymous fontforge cvs sourceforge net:/cvsroot/fontforge login;
cvs -d:pserver:anonymous fontforge cvs sourceforge net:/cvsroot/fontforge
co fontforge;
cvs -d:pserver:anonymous cvs savannah nongnu org:/sources/freetype login;
cvs -d:pserver:anonymous cvs savannah nongnu org:/sources/freetype co freetype2;
svn co;
gedit freetype2/include/freetype/config/ftoption.h
cd ~/src/libspiro;
su; make install; exit
./configure --enable-pyextension --enable-type3 --enable-pasteafter \
--enable-tilepath --enable-double --enable-device-tables \
--with-capslock-for-alt --with-freetype-bytecode \
--with-freetype-src=../freetype2 --with-x --with-pango;
su; make install; exit

This is the "font view" window I see:

Going to File, X Resource Editor, and editing the Font Family items in
the FontView pane to


and Saving As ~/.FontForge/theme.txt and checking storing filename in
preferences, and then restarting fontforge, gives the same result
using a anti-alised (pango) font:

Has anyone else had this problem and fixed it?

I'd also like to mention I tried installing Michał Nowakowski's
excellent ClearLooks theme from - this also
doesn't help, although in the screenshot on that wiki page its fine.

cd ~/.FontForge/;
curl -O;

File, Preferences, Select ~/.FontForge/theme-clearlooks.txt - File, Quit


FWIW, I also managed to make a theme.txt that uses his theme that segfaults:


From: George Williams <gww silcom com>
Date: 2009/1/16
To: Dave Crossland <dave lab6 com>
Cc: fontforge-users <fontforge-users lists sourceforge net>

To me, this looks like a bug in pango.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]