Query about Xft2 and Pango, GDK dependency.

Hi all !!

	I have download the fcpackage (02-07-17) tarball and I have just upgrade the freetype libs to 2.1.2. I am going to install the fcpackage libs and also gdk, pango stuffs. But I'd like to ask about the dependency problem first.

	I've read some previous post regarding 'fontconfig, xft2, .... play together', but I think there is no ans for me, So I post a new one for this!!

	At this point, I know that, Xft2 is derived from xft1 which font config management  function is split into fontconfig libs. and Xft2 doesn't requires xrender; pango and gdk do require Xft1, originally, but should be work fine with Xft2 and friends. OK, do I have some wrong interpretation?? If there is, pls correct me : ).

	When configuring and compiling fontconfig, I find that, I can't control the configure script to install the pkgconfig file (.pc) to /usr/lib/pkgconfig, while install others under /usr/X11R6 .. and finally I just manually put the fontconfig.pc into where I want. It is a fact or a convention that, we should install the .pc file with same libprefix as other so files within the same package ? Or, I can config it via some means, or anything else ??

	While, I'm going to compile the libs, I started from fontconfig, then, Xft (should be v2), yet, I find that, the make install overwrite the original includes dir of Xft1. Is it neccessary to install Xft2 and Xft1 parallelly? Or just override the Xft1 with Xft2 ??

	Before I compile and install the Xft2, I've tried to compile the Xft1, but, I don't know how to configure the process, as I can't find the configure script ... what should I do?? It's also the same situation for Xrender libs.

	Afterall, does all these four libs is necessary? To compile and install it ?? What's the dependency of these libs ? And what's the config file for this ?? /etc/fonts/fonts.config or /etc/X11/XftConfig?? While studying the configure files, and likes inside, it seems that, Xft1 will use fontconfig if there exist. For Xft2, it still require Xrender and also fontconfig.

	When I run configure in pango, it haven't detect anything about fontconfig. It also doesn't detect the freetype, and Xft header correctly. I am totally stalled on it... any idea to solve it??

	checking for freetype-config... /usr/bin/freetype-config
	checking for FT_New_Face in -lfreetype... yes
	checking For sufficiently new FreeType (at least 2.0.1)... yes
	checking freetype/internal/tterrors.h usability... no
	checking freetype/internal/tterrors.h presence... no
	checking for freetype/internal/tterrors.h... no
	checking for FT_Get_First_Char... yes
	checking for XRenderFindFormat in -lXrender... yes
	checking for XftFontOpen in -lXft... yes
	checking X11/Xft/XftFreetype.h usability... no
	checking X11/Xft/XftFreetype.h presence... no
	checking for X11/Xft/XftFreetype.h... no

	Sorry for my long post, filled with Questions !!

Zenith Lau

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]