Re: Reinstate support for OS X versions older than 10.9


Just to add to this, GStreamer 1.x currently supports OS X 10.8, so it
would be great if GLib continued to support at least that. Support for
older versions should, I suppose, be welcome as well since Ryan says
he's willing to maintain it. :)


On Wed, Sep 23, 2015 at 4:17 AM, Ryan Schmidt <gtk ryandesign com> wrote:
Hello, I'm the maintainer of glib2 in the MacPorts package management system.

glib 2.46.0 was recently released, and attempting to configure it produces this error:

checking OSX version >= 10.9.0... no
configure: error: OSX version is too old!

glib 2.45.2 and earlier worked fine on older versions of OS X, but 2.45.3 and later claim to require 10.9.

My understanding is that the implementation of GNotification support for OS X [1] necessitated this 
increase in minimum OS version. But this huge jump in minimum OS version makes glib unusable on hundreds of 
older Mac models [2] that cannot be upgraded to OS X 10.9 that were previously able to use glib. I urge you 
to reconsider this action and reinstate support for older versions of OS X by making the GNotification 
support optional. Clearly, since GNotification support was just added, no existing apps that used glib and 
that already worked on OS X can have required this functionality.

I originally expressed this concern in the issue tracker [1] but was advised to bring it up on the mailing 
list for discussion instead.

In response to my comment in that ticket, doubt was expressed as to the usability of glib on older systems, 
even prior to this. I can at least tell you that Graphviz, which uses glib, worked fine all the way back to 
OS X 10.4, which is the earliest system I tested. I'm happy to run your test suite on older systems and 
report bugs for any problems found.



gtk-devel-list mailing list
gtk-devel-list gnome org

~Nirbheek Chauhan

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]