Re: Missing #include from glib/gwin32.c ?

Apparently at ntdef.h, try that I didn't tested.

On Oct 16, 2015 10:23 AM, "John Emmas" <johne53 tiscali co uk> wrote:
I just updated glib (from git) and tried to build the glib-2-44 branch, using MSVC8.  I'm getting a compiler error at line 568 which looks like this:-

      typedef NTSTATUS fRtlGetVersion (PRTL_OSVERSIONINFOEXW);

Basically, my compiler doesn't recognise NTSTATUS.  If I substitute LONG instead of NTSTATUS, everything builds okay, so I'm assuming there's a missing #include.  I tried #including <ntstatus.h> and when that didn't work, I tried #include <winnt.h> (but that didn't work either).

Can anyone advise me what needs to get #included in order for NTSTATUS to get recognised?  Thanks.

P.S. I assume the same problem might also exist in 'master' although I haven't had a chance to try that yet.
gtk-devel-list mailing list
gtk-devel-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]