Re: a new combo box

On Sun, Dec 28, 2014 at 7:42 PM, Emmanuele Bassi <ebassi gmail com> wrote:

just a bunch of comments going through the commits.

Thanks for this!


as for the overall naming: I think "combo box" does not entirely
apply, given that the entry is not only optional, but also part of the
drop down, instead of being an entry *with* a drop down. maybe
something like "GtkDropdown"? or "GtkDropList"?

I've spent some more time on the branch and ended up reworking things
a bit more. I've incorporated most of your suggestions. Wrt names,
I've renamed things to GtkOptionList (for the list widget) and
GtkOptionButton for the button with the popover. Still not great. The
test app is now called testoptionlist, and shows a more stuff:
multi-selection, and various alternative uses of the list widget
without a button.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]