Re: GTK Drag'n'Drop problem

On 22/02/2014 22:30, Syed Akbar wrote:

I am afraid this is might not be the right place to ask: there is a dnd problem with GTK + Win 7/8 + Kaspersky or TuneUp Utilities or Camtasia. I've tried to debug the problem, but I am not very familiar with C/C++ and Win32 programming.

I just detected that in "gtkdnd.c/gtk_drag_button_release_cb()" the value of "gdk_drag_context_get_selected_action (info->context)" returns 0. Also "_gtk_drag_dest_handle_event()" is never called. I tried to trace the value of context->action but couldn't figure out where exactly the initial value of context is assigned.

Any idea how to proceed?

What version of GTK+ are you using? For the Windows platform, DND was quite seriously broken between v2.20 and v2.24 but the problem got fixed around Sept 2011 (both for gtk+2 and gtk+3 AFAIK).

Also, you mentioned that your problem exists when using Kaspersky, Tuneup Utilities or Camtasia. Does the problem go away if you run your app on a system that doesn't use those products?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]