Re: minutes of the gtk+ team meeting - 2009-01-20

On Fri, Feb 20, 2009 at 5:16 PM, Michael Natterer <mitch gimp org> wrote:
> On Fri, 2009-02-20 at 16:03 -0500, Matthias Clasen wrote:
>> On Fri, Feb 20, 2009 at 3:35 PM, Christian Dywan <christian imendio com> wrote:
>> > Am Fri, 20 Feb 2009 20:25:54 +0100
>> > schrieb Torsten Schoenfeld <kaffeetisch gmx de>:
>> >
>> >> Tristan Van Berkom wrote:
>> >> > Sorry I missed the last meeting, is there anything you need me
>> >> > to do for GtkActivatables ?
>> >>
>> >> Maybe <>,
>> >> "gtk_activatable_reset has a very generic name"?
>> >
>> > I second that, we mustn't miss that before the stable release.
>> >
>> > And I share the concern that _reset should be _reset_action, not only
>> > for the sake of object oriented languages but for clarity as well.
>> But it is not resetting the action. That would just be a misnomer. If
>> you want a clearer name, it would be something like
>> gtk_activatable_sync_appearance_properties
> What about gtk_action_resync() ?

I would propose gtk_activatable_sync_action_properties(), because it is the
GtkActivatable in this case that must update itself completely from the related
GtkAction's properties (almost the same as what mclasen mentioned, except
note that _reset() is also responsible for syncing action properties that
are unrelated to the GtkActivatable's appearance).

Maybe gtk_activatable_resync() also, only that its also called for the initial
property synchronization...

Just shooting out possible names here, I dont really have a preference
myself, gtk_activatable_reset() does the trick for me (only I would have
thought from the name it would be clear that the activatable is resetting
itself... not the action).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]