Re: modification on treeview blocks or crashes if using g_threads


after thinking a little bit (at least a few days) about the problem, i
tried modifying the data by detaching the store from the treeview before
modifying the data within a thread and now it works.

but that's not a real solution.

if u have a suggestion why it doesnt work without detaching i'll be glad
to hear from you (please cc to my email address)!


On Thu, 2008-02-07 at 16:07 +0100, Martin SCHREIBER wrote: 
> hi there,
> i'm not sure if this is a bug so i'm going to post this here and ask for
> your advice.
> maybe there's a mistake in using the g_threads in the attached program?
> there are 2 ways how the program sucks:
> 1) sometimes it just hangs up directly after start. if i move parts of
> the window over the screenborder and back, the graphic isnt restored.
> 2) sometimes it updates the list (as it should be) but if i click on the
> list a lot of times i get the following error message:
> ** ERROR **: file gailtreeview.c: line 3755 (traverse_cells): assertion
> failed: (row_path != NULL)
> and the program aborts.
> greez,
> martin
Martin Schreiber

| Im Muehltal 48
| 91171 Greding

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]