Re: gvfs status report
- From: Murray Cumming <murrayc murrayc com>
- To: Alexander Larsson <alexl redhat com>
- Cc: "gnome-vfs-list gnome org" <gnome-vfs-list gnome org>, "gtk-devel-list gnome org" <gtk-devel-list gnome org>
- Subject: Re: gvfs status report
- Date: Fri, 16 Feb 2007 11:26:32 +0100
On Fri, 2007-02-16 at 08:35 +0100, Alexander Larsson wrote:
> On Thu, 2007-02-15 at 19:32 +0200, Stefan Kost wrote:
> > Hi Alex,
> > > GCancellable
> > > GFile
> > > GInputStream
> > > GInputStreamSocket
> > > GFileInputStream
> > > GOutputStream
> > > GFileOutputStream
> > > GOutputStreamSocket
> > > GSeekable
> > > GFileInfo
> > > GFileEnumerator
> > > GMountOperation
> > > GVfs
> > >
> > Just one thing - is this okay with the GLib to use 'G' as a prefix and not e.g.
> > 'GVFS' or 'GIO'?
> Its certainly nothing new. It goes with the general glib naming of
> things like GMutex, GThread, GModule, GIOChannel, GArray, etc.
> Why shouldn't it be ok?
If these objects are strongly associated with each other, and not very
useful without each other, it would be helpful for them to have common
prefixes so they look like part of a sub-system, rather than getting
lost in the rest of glib.
If they are generally useful individually, ignore this.
murrayc murrayc com
] [Thread Prev