Re: Get rid of deprecated widgets

Am Mittwoch, den 05.12.2007, 12:17 +0100 schrieb Mikael Hermansson:
> Hello! Some thoughts
> For years now there has been widgets that is deprecated in Gtk+
> GtkList
> GtkCList
> GtkFileSel
> GtkCTree
> GtkItemFactory
> Imho it really is time to kill this or atleast add an option in
> Makefile/configure to not include them as default.
> If there still is apps that using this old API(is there any???) they
> should just copy&paste it to theyr project or just migrate to the new
> widgets.

I am also supporting this idea for a long time: There is no point in
deprecating code, if you plan to support it forever. Regarding ABI
stability: That old code could be moved into

So programs that still want to use deprecated widgets:

- link against an old version of gtk - for what other reason gtk is
using libtool's -version-info switch?
- link against libgtk-compat-2.0.

Its really pointless to pay of this old stuff everyday, when none of
your daily programs uses those old and deprecated symbols.

Mathias Hasselmann <mathias hasselmann gmx de>

Attachment: signature.asc
Description: Dies ist ein digital signierter Nachrichtenteil

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]