Re: g_hash_table_steal_extended()

On Sun, 2006-11-19 at 09:02 -0800, Ken Ishii wrote:
> I just came up with that name to go along with the
> g_hash_table_lookup()/g_hash_table_lookup_extended() convention. But yes
> you're right, it's not very self-explanatory.

I've often thought of suggesting such a function myself.  "Pop" seems
like a good verb for it.

gpointer g_hash_table_pop (GHashTable *hash_table, gconstpointer key);

Matthew Barnes

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]