Re: Which are the plans for Cairo?

On Tue, 2003-09-02 at 22:44, Havoc Pennington wrote:
> On Tue, Sep 02, 2003 at 05:11:32PM -0400, Owen Taylor wrote: 
> >  void my_widget_render (GtkWidget *widget, cairo_t context)
> >  {
> >    /* Draw with cairo commands */
> >  }
> > 
> > There are doubtless going to be some areas where cairo won't be
> > quite "GTK-ish" - the type names being one glaringly obvious
> > one, but if we pay attention now, we can get most difficulties
> > fixed.
> Start with "cairo_t" - what if we had "gtk_t", what would that be ;-)
> If nothing else you can't language bind that type to a language with
> namespaces. surface = new cairo::t; or something

Well, the _t is part of the naming convention like iconv_t, dev_t,
so it wouldn't appear in a language binding.

I think we'll have to consider cairo_t a C-specific abbreviation
for cairo_context_t and encourage people to use names like

in language bindings.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]