RE: gtk+-2.3/2.4 backwards compatibility

Jens Ansorg wrote:
> But there is one other app I use in a Gnome/gtk environment: 
> eclipse ( The provided binary stopped 
> working right after I upated gtk+ form 2.2 to 2.3 (after the 
> updates of glib and pango before eclipse did still work).

Maybe eclipse uses the Java GTK+ bindings. GTK+ 2.3 also kills gtkmm:

A backtrace from you would be interesting. Maybe it's the same thing.

But do remember that 2.3 is unstable. That means that it's unstable. 
That means that you shouldn't be installing it on top of GTK+ 2.2 in 
your regular prefix. Use a separate prefix for experimental stuff. 
jhbuild makes that very easy.

Murray Cumming
murrayc usa net

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]