On Thu, 2003-03-13 at 17:24, Owen Taylor wrote: > - Supporting operations on a non-monitored directory is > going to add complexity to file system implementations. > Perhaps we should rename GtkFolderMonitor to GtkFileFolder > and move list_children() and get_info() to there. Yeah, I think the way the draft works is a bit messy, because getting the list of files is separate from the object that would update on the status of the files. So I think we should go for this approach. (I think the draft also has a race condition because you can't get the list of file and create the monitor at the same time...) > - Is additional information needed in GtkFileInfo - > is-symlink? atime? ctime? permissions? I think we'll want symlink and permissions; the former to decide when to superimpose the "arrow" icon, and the latter to gray out the files that cannot be opened. Probably the permission field doesn't need to be the full permission bitfield though, the backend could just say if the file is readable/writable for the current user and the GUI would gray out items accordingly. -- Ettore
Attachment:
signature.asc
Description: This is a digitally signed message part