about Xft2

I don't know where to post the question, but I think the error will affect 
pango and gtk+ 2.1.x.

I compiled freetype 2.1.2 and then untar fcpackage_2.0, installed fontconfig, 
Xft on my system, then I built pango 1.1.2 and gtk+ 2.1.1, but when I run the 
demo program gtk-demo, it generate a segement fault error.

I use locale with zh_CN.GB2312, I have tried to trace the source code, then I 
found in the xftglyphs.c which in fcpackage/Xft, has a function called 
XftCharIndex(Display* dpy, XftFont* public, FcChar32 ucs4), 
and this function generate the error.

I think the first statement of this function has wrong, 

XftFontInt* font = (XftFontInt*)public;

becuase XftFontInt's memory size is bigger then XftFont, and convert XftFont* 
to XftFontInt* without initialize XftFontInt, after the coversion the 
function calls font->has_table[ent].ucs4 != ucs4, this cuase the error, 
becuase font->hash_table doesn't get it memory, this member doesn't exist in 
XftFont structure.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]