Re: Some name changes for multihead


Owen Taylor <otaylor redhat com> writes:

> The other ones I want to change (also very common, 
> unfortunately) are:
>  gdk_display_pointer_ungrab()  => gdk_display_ungrab_pointer()
>  gdk_display_keyboard_ungrab() => gdk_display_ungrab_keyboard()

I think that the current API makes a lot of sense since it keeps
the related functions together visually as well as when sorting

GdkGrabStatus gdk_pointer_grab       (GdkWindow    *window,
void          gdk_pointer_ungrab     (guint32       time);
gboolean      gdk_pointer_is_grabbed (void);

GdkGrabStatus gdk_keyboard_grab      (GdkWindow    *window,
void          gdk_keyboard_ungrab    (guint32       time);


> This change is to fit them into the standard 
>  Subject Verb Object
> Pattern that we try to follow for GTK+ function names, and
> matches, for example:
>  gdk_display_list_devices()

you might be right that it fits better but then I've never liked the
current scheme that much.

Salut, Sven

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]