Some name changes for multihead

I want to change the name of a few functions added in 
the multihead changes. 

These are _very_ common functions, so I'm afraid this 
will cause some problems for people who are programming 
to the API already, but then again, it will be a very
mechanical to fix them. (I can provide a magic perl

The most important ones are;

 gdk_get_default_display() => gdk_display_get_default()
 gdk_get_default_screen()  => gdk_screen_get_default()

The reason for this is that we already have:


(Along with other similar, but less identical functions 
like gtk_clipboard_get().)

I would leave gdk_get_default_root_window(), 
gdk_x11_get_default_[root_xwindow,xdisplay] as is,
since we don't have "GdkRootWindow", "GdkRootXWindow",
or "GdkXDisplay" objects.

(There is some arguemnt for gdk_window_get_default_root();
that seems rather clunky to me... might still be 

The other ones I want to change (also very common, 
unfortunately) are:

 gdk_display_pointer_ungrab()  => gdk_display_ungrab_pointer()
 gdk_display_keyboard_ungrab() => gdk_display_ungrab_keyboard()

This change is to fit them into the standard 

 Subject Verb Object

Pattern that we try to follow for GTK+ function names, and
matches, for example:



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]