Re: Outstanding patches, #58330



>
> Replacing:
>
>   if (gtk_debug_flags & GTK_DEBUG_TEXT)
>     _gtk_text_btree_check (tree);
>
> With:
>
>  GTK_NOTE (TEXT, _gtk_text_btree_check (tree));
>
> Actually would work, since the defnition is:
>
> #define GTK_NOTE(type,action)                G_STMT_START { \
>     if (gtk_debug_flags & GTK_DEBUG_##type)                 \
>        { action; };                          } G_STMT_END
>
> But the name is more than a little confusing. What it was
> meant for, was stuff like:
>

I agree the name is confusing, but GTK_NOTE(TEXT,
_gtk_text_btree_check(tree)) would
actuall be more efficient in the nodebug version, since the whole macro will
be defined away,
wouldn't it ?

Btw, to make things a bit more interesting, gtktextview.c has its own
private debugging setup
with the DV macro.

Matthias





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]