Hi Owen,

> While I'm complaining about bad function names, we have:
> #define G_MICROSEC 1000000
> Which is wrong, unless your units are picoseconds.

I simply copied it from Solaris /usr/include/sys/time.h and renamed it to
G_MICROSEC. In hindsight i agree, that it isn't a good idea.

> I'd suggest
> #define G_MICROSECS_PER_SEC 1000000
> or maybe
> #define G_MILLION 1000000
> or maybe just forget it. After all, I think 1e6 is a valid
> integer constant in C. (gcc accepts it anyways.)

Yea, I'll remove it.


P.S.: I hope every Programmer out there knows, that micro is 1e-6.... ;-)
Sebastian Wilhelmi                   |            här ovanför alla molnen
mailto:wilhelmi ira uka de           |     är himmlen så förunderligt blå   |

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]