G_MICROSEC



While I'm complaining about bad function names, we have:

#define G_MICROSEC 1000000

Which is wrong, unless your units are picoseconds.

I'd suggest

#define G_MICROSECS_PER_SEC 1000000

or maybe

#define G_MILLION 1000000

or maybe just forget it. After all, I think 1e6 is a valid
integer constant in C. (gcc accepts it anyways.) 

Regards,
                                        Owen 




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]