I broke gnome!

well, not really.  I just can't find it.

I just updated my system using Ximian Redcarpet, and it brought me from
gnome-1.2 to gnome-1.4.  Seems like a good deal, except for that now
when I try to compile anything that requires gnome support, it complains
that it can't find gnome.h.  gnome-libs-devel-1.4 is installed, and
gnome.h resides in /usr/include/gnome-1.0/.

so, just add /usr/include/gnome-1.0 to my -I comiler flags, right? 
Well, yeah.  But the whole point of gnome-config is so that you don't
have to worry about where the include files and the libraries are. 
gnome-config --include returns the wrong include directory, but the
correct version.

[mfe]# gnome-config --includedir
[mfe]# gnome-config --version

has this happened to anyone else? Did gnome-config just forget to get
updated?  How can I fix this?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]