Re: [Multi-valued V2 (grilo) 11/12] core: Merge GrlDataMulti into GrlData

On Tue, 2011-03-01 at 11:18 +0000, Iago Toral wrote:
>  Maybe GrlProperty was not a good name after all, I'd rather keep 
>  grl_data_set/get_property like they were, it is confusing otheriwse.
>  I see two options:
>  a) Rename GrlProperty to something else. Maybe GrlRelated?
>  b) Use grl_set/get_related_property instead of grl_set/get_property
> for 
>  setting/getting GrlProperty instances.
>  Right now I think a) is the best choice. 

I don't like it very much neither.

What about GrlRelatedData or GrlRelatedKeys? Or are them too long?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]