Re: Saving a histogram plot

Hi Andreas,

Based on Jean's answer I figured out what was wrong. It seems that I
only replied to him. I am sorry about that. The short answer is that I
did something stupid: I saved an .xls file with the .gnumeric
extension (but I kept the type to be MS Excel). Here is the longer
answer I sent to Jean:

"Thanks for your reply. Indeed the file was corrupted. The original
file was a .xls file that I downloaded from the government website and
I wanted to save it as a gnumeric file. I changed the name to
file.gnumeric but I forgot to change the type of the file to gnumeric.
So the file had the .gnumeric extension but it was, in fact, still a
.xls file. I am not sure how I missed that because gnumeric certainly
warned me about the incompatible file types."

Thanks again for your replies and for gnumeric.

On Thu, Jan 27, 2011 at 6:32 PM, Andreas J. Guelzow <aguelzow pyrshep ca> wrote:
On Thu, 2011-01-27 at 09:25 -0500, Marius Ionescu wrote:

I am trying to draw a histogram based on the income distribution in
US. I can draw the picture I want, but the next time I open the file
the picture is blank. I am using Gnumeric 1.10.8 on Ubuntu 10.10.
Here are the steps that I perform:

The bins (intervals) are:

0 15000 25000 35000 50000 75000 100000 200000

and the percentages  are:

8.1 9.0 9.7 13.6 19.4 14.3 26.0

This means that 8.1 percent lie between 0 and 15000, and so on. I
select the first row, press Ctrl, and then select the second row. Then
I press the chart button and I select "Statistics" and from the
available options I select "Histogram". The graph is as it should be
(that is, scaled to take into account the fact that the intervals do
not have the same length). I save the file and exit gnumeric. The next
time I open it with Gnumeric, the picture is blank and if I
right-click and select properties, I do not see any histogram and data
in there. They vanished. I tried saving the file as a gnumeric file
and as xls. The same result. If I open the xls file with OpenOffice, I
can see a graph, only that it is incorrect (all the scaling is gone;
it is just a plain bar graph of the original percentages). But in
Gnumeric I don't see even this graph when I open it again.

Is this a (known) bug in Gnumeric? Am I doing something wrong?

Hi Marius,

It seems to be unlikely that you are doing something wrong that could
cause this. Please file a report at including the
file you are saving.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]