compiling error for gnumeric 1.2.13

I try to install gnumeric on an Altix SGI running with Suse enterprise 9 sp3 or 10 sp1.
Because of GTK+ version installed on these O.S., the lastest gnumeric version I can install is gnumeric v.1.2.13.
After configure, when I run make, it stops with an error in the gnumeric-expr-entry.c file :

gnumeric-expr-entry.c:515:65:error: macro " GSF_CLASS_FULL" requires 10 arguments, but only 7 given

How can I workaround this problem without upgrading standards packages of Suse ?

Thanks for any solution

Yves# " This e-mail and any attached documents may contain confidential or proprietary information. If you are not the intended recipient, please advise the sender immediately and delete this e-mail and all attached documents from your computer system. Any unauthorised disclosure, distribution or copying hereof is prohibited." " Ce courriel et les documents qui y sont attaches peuvent contenir des informations confidentielles. Si vous n'etes pas le destinataire escompte, merci d'en informer l'expediteur immediatement et de detruire ce courriel ainsi que tous les documents attaches de votre systeme informatique. Toute divulgation, distribution ou copie du present courriel et des documents attaches sans autorisation prealable de son emetteur est interdite." #

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]