Re: paradox support: help needed

On Mon, Nov 03, 2003 at 11:47:07AM -0500, Jody Goldberg wrote:
On Mon, Nov 03, 2003 at 04:41:33PM +0100, Uwe Steinmann wrote:
On Wed, Oct 29, 2003 at 01:17:46PM -0500, Jody Goldberg wrote:
On Wed, Oct 29, 2003 at 07:04:35PM +0100, Uwe Steinmann wrote:

Does pxlib use pkg-config ?  That would be ideal.
I wouldn't mind to use pkg-config, if I just knew how to
get it going. Is pkg-config something gnome specific?

It's trivial.  pkg-config is part of so its fairly
agnostic.  All that is required is to install a .pc file

Jody, sorry for bothering you again. I just thought about a potential
problem that occurs, if pxlib is availabe but doesn't have libgsf1
support. There seems to be no way to handle this with pkg-config
except for creating two libraries and two .pc files for e.g. libpx and
libpx-gsf. If I did the configurartion by myself, I would simply
check for a function within libpx that uses libgsf1. pkgconfig doesn't
appear to do a test compile but rather relies only on the information
in the .pc file.
Is there any clean solution beside the two library way?

Not really.  The fundamental issue always comes down to wether or
not the functionality is there at run time too.  Packagers get
nailed if there are two versions of a library that claim to be the
same but do not have the same symbols.
Ok, I'll see what I can do.


  MMK GmbH, Universitaetsstr. 11, 58097 Hagen
  Uwe Steinmann mmk-hagen de
  Tel: +2331 840446    Fax: +2331 843920

Attachment: signature.asc
Description: Digital signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]