Re: Gnumeric compilation error

On Tue, 2003-04-01 at 16:16, Alexander Weber wrote:
Yep, indeed i already tried to compile libgda (v0.2.96).

ugh, that's very old. Are you trying to use gnumeric 1.0.x, right?

 But it needs a
newer bonobo than i have(>=1.0.9). So i tried to compile the newer bonobo
(v1.0.22) but it needs newer gnome-libs than i have (>=1.2.7). So i tried
to compile newer gnome-libs (v1.2.23) but i got this:

yeah, you will have to upgrade those libs.

gcc -g -O2 -Wall -Wunused -o .libs/gnome-dump-metadata -L/usr/lib -lglib
gnome-dump.o .libs/ -lglib -lm
-ldl -lz -lm ../support/.libs/ -lz -lm -L/usr/lib -lesd
-laudiofile -lm -L/usr/lib -laudiofile -lm -ldb1 -L/usr/lib -lglib
-ldl -lz -lm
gnome-dump.o: In function `main':
/root/contrib/gnome-libs-1.2.13/libgnome/gnome-dump.c:75: undefined
reference to `__db185_open'
collect2: ld returned 1 exit status

hmm, I guess the gnome-libs package is wrong, or missing some -l switch,
since this is a dependency of gnome-libs itself, not libgda.

And now i need some valium or I'll go completely mad!

can't you upgrade to GNOME 2/gnumeric 1.1.x/libgda 0.11 ? The problem
seems to be bad package dependencies on old packages (GNOME 1.4). Which
distro are you using?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]