Guppi 0.40.3 Released

Your Guppi development team is pleased to announce the release of
Guppi 0.40.3, code name "I forget most of it but it was clever".

Guppi is a GNOME-based framework for graphing and interactive data

* What's New

        - Miscellaneous bug fixes.
        - The guile dependency has been removed.
        - The distributed .spec file now actually works.
        - We no longer crash on PPC.
        - We can now add/delete series in Gnumeric.
        - Graphs in Gnumeric can now use dates.
        - Rendering fixes to produce crisper-looking graphs.
        - A more sensible marker size range in bubble plots.
        - The code base has been purged of lots of cruft.

* Friends of the Fish

        Roy-Mange Mo, Jonathan Blanford, Greg Leblanc and Adrian Custer
        helped to fix and test the new .spec file.

        Morten Welinder and Etsushi Kato helped resolve the PPC issues.

        Jody Goldberg implemented the cool new Gnumeric stuff.

* Availability

        You can get the Guppi 0.40.3 tarball here:


        An RPM for Red Hat 7.2 is available at:

        A source RPM is at:

* Information

        Visit to learn more about

* Prerequisites

        Guppi basically requires a complete and fairly up-to-date
        GNOME 1.4 installation, such as Ximian GNOME. You will need to
        have (among other things)

                - bonobo 1.0.8
                - gnome-print 0.28


        To use this version of Guppi to insert graphs into your Gnumeric
        spreadsheets, you *must* have Gnumeric 1.0.3 (or better) with
        Bonobo support installed *before* compiling Guppi.

* Caveats

        Be aware that Guppi is still EXPERIMENTAL software, and
        support for graphs in Gnumeric is still VERY INCOMPLETE.
        Feedback and bug reports are always welcome, but you don't
        need to tell us that lots of features are missing: We already
        know that.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]