The continueing gnumeric build saga...

Thank You.

I tried a short cut (I hear people cringing already) and simply copied
all the files from /usr/local/lib (they were all gnome-print files) to

This appeared to work as ./configure passed the GnomePrint test...and
died on the very next line.

Found libglade-0.14.  Requires 0.16 or higher.

And is not responding at the moment.


Sorry, I just needed to say that.

Could someone just reassure me that this will compile in the end?  And
that this is not some sort of cruel joke used to punish me for what I
did with that cheerleader, squirrel and bicycle pump?  I am sorry for
that.  Really, I am.

Thanks again.

Bob Washburne

Mathieu Lacage wrote:

hi bob

I feel pain for you :)

1) to fix the original problem, all you needed to do was to install the
gnome-print-devel rpm (its name is probably not this one but one

2) to fix your current problem which is to get gnumeric to use the
library you just built from tarball, you have 2 solutions. What happened
when you typed configure;make;make install is that the library was
installed in /usr/local by default.

    - so you can recompile the tarball with the --prefix=/usr option to
    configure (I would suggest rm -rf gnome-print first so that you
    avoid all problems). This is the easiest way.
    - you can get gnumeric to use the library in /usr/local. This has a
    number of issues. The main one is that you need to remove the one
    which is in /usr (the one you installed through rpm). Then, you need
    to make sure LD_LIBRARY_PATH contains /usr/local/lib, PATH contains
    /usr/local/bin and GNOME_PATH contains /usr/local.

I hope this helps,


Le 01 May 2001 23:13:07 -0400, Bob Washburne a écrit :
The subject says it all.

I want to build gnumeric 0.64 with a couple of modifications (I
increased the maximum column count and decreased the row count.  Thanks
for the help, Jody!) under RedHat 7.1

-) I downloaded the 0.64 tar ball from the gnome archive.

-) ./configure dies with a GnomePrint library "Not Found"

-) I checked and the gnome-print-0.25.rpm was installed, but it only
appears to contain docs and fonts.  No library.

-) there exists /use/lib/, but it was created back in

-) I downloaded the gnome-print tar ball from the gnome archive.

-) for gnome-print I ran ./configure, make, make check, make install,
make clean all without errors.

-) No new file was added to /usr/lib.  gnumeric/configure still dies
with GnomePrint not found.

-) gnumeric/configure uses "gnome-config --libs print" to test for the
library.  Running this command in a shell yeilds an "unknown library"

-) no man page for gnome-config

-) gnome-config --help-all gives interesting information.  "print" is
not one of the standard libraries which it knows about.  The only way
for it to work is for a /usr/lib/ to exist from which it can
get the information.  It doesn't, so this test would appear to be doomed
to failure.

QUESTION 1) How do I tell whether I have the gnome print library(s)
installed correctly?  Just what are their names and where are they

QUESTION 2) How do I configure and build gnumeric 0.64 under RH 7.1?

Thanks much for all your help.

Bob Washburne

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]