[GnomeMeeting-list] compiling ekiga 2.0.1 for Etch

I'm trying to get ekiga working on a Debian Etch 2.6.15 box and it's proving
a nightmare. I first tried installing the binaries from the ekiga site. I
tried both the etch version and the ekiga-snapshot version. They both start
and the sound and video are working. The problem is that every time I
actually connect to anything (the test number for example), ekiga crashes
with the message: ekiga: symbol lookup error: /usr/lib/libopal.so.2.2:
undefined symbol: speex_echo_state_init
I sent in a report via buzilla but it seems it's not an Ekiga problem. I'm
not sure whose problem it is (besides mine) but googling hasn't helped. Not
to be discouraged I decided to compile it myself and maybe understand what
my problem is (assuming it would throw up compilation errors). I went to
Ekiga's home page. You will see that there are 3 tarballs. I started with
the ekiga-2.0.1 and ran configure. It complained about the pwlib version so
I downloaded compiled and installed the pwlib-1.10.0 tarball. That
eliminated the pwlib problem. I tried configure again on ekiga and it now
wants opal headers. Aha! The third tarball is opal-2.2.1 so I downloaded
compiled and installed that but that doesn't provide the opal headers. The
only opal headers I can find are in the deb libopal-cvs-dev package but
that's going to give me version problems. I can't, for the life of me, find
the opal headers that will play nicely with ekiga-2.0.1.
Any ideas on either (1) the original problem or (2) where I can get the opal
headers would be greatly appreciated.
Thanks for any help.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]